Need upgrade Rated 5 out of 5 stars

It was neat while it lasted but it's not compatible with 3.5.1 Hopefully it will be fixed soon.