Bewertet mit 4 von 5 Sternen

Not compatible with FireGestures

Diese Bewertung wurde für eine vorherige Version des Add-ons (0.9) abgegeben.